[SOLVED] Why I can't import torch windows

Issue

I installed python 3.8.0, numpy 1.22.3, pytorch 1.11.0 .
and I tried this code:import torch.
But I’m getting this error:

IMPORTANT: PLEASE READ THIS FOR ADVICE ON HOW TO SOLVE THIS ISSUE!

Importing the numpy C-extensions failed. This error can happen for
many reasons, often due to issues with your setup or how NumPy was
installed.

We have compiled some common reasons and troubleshooting tips at:

    https://numpy.org/devdocs/user/troubleshooting-importerror.html

Please note and check the following:

  * The Python version is: Python3.8 from "C:\anaconda3\python.exe"
  * The NumPy version is: "1.20.1"

and make sure that they are the versions you expect.
Please carefully study the documentation linked above for further help.

Original error was: DLL load failed while importing _multiarray_umath: 

During handling of the above exception, another exception occurred:
...

What should I do? I’m a beginner of python, so please help me!!

Solution

** From the PyCharm Python Console you can digit ctrl+alt+S to access at the Project:pythonProject > Python Interpreter. Down in the page, you should see a + button to access to all available packages. Please, here search for torch and install it. Now try:**

import torch

Answered By – G E

Answer Checked By – Pedro (BugsFixing Volunteer)

Leave a Reply

Your email address will not be published. Required fields are marked *