[SOLVED] Wamp Server Error [Local Server – 2 of 3 services running]

Issue

I am new to wamp servers and trying to install wampServer 3.1.0 on my windows 10 machine .

Somehow it is not installed properly and is having configuration error .

At present “Wamp server is still in orange state and is throwing the error”

2 of 3 services running

As of my understanding either of Apache,MySQl orPHP is not working .
On further investigation I found that Apache is ok.
But on running mysql.exe(C:\wamp64\bin\mysql\mysql5.7.19\bin) it is throwing :

ERROR 2003 (HY000): Can’t connect to MySQL server on ‘localhost’
(10061)

which lands me to SO-32519474 ,
I tried following the steps ,but it looks good to me in my case .
On further searching I find that wampmysqld64 is stopped in the services.
when I am trying to restart it I am getting the error
enter image description here

I am stuck up here and have no further clue how to get it fixed

Any help is highly appreciated.

Solution

I got to this SOI=35670755 and executed this command

mysqld –initialize

inside (C:\wamp64\bin\mysql\mysql5.7.19\bin)

this fixed my issue.

If in case you still have issues refer to this post
Wamp Server Error [Local Server – 2 of 3 services running]

**Edit:

mysqld –initialize

may not be a great solution ,its kind of patch work.
It leads to issues with username and password.
The best way to install xampp is completely described in the following links

Wamp Server Error [Local Server – 2 of 3 services running]
&
Error While Logging into MYSQL

Answered By – Nihar

Answer Checked By – Candace Johnson (BugsFixing Volunteer)

Leave a Reply

Your email address will not be published.