[SOLVED] Updating to latest version of CocoaPods?

Issue

I’m having some issues installing Alamofire 4.0 into my project.

I’ve got the latest version of Xcode, running Swift 3, and when I try to install alamofire I’m getting like 800 compiler errors.

Apparently

CocoaPods 1.1.0+ is required to build Alamofire 4.0.0+

[!] some_cocoapod requires CocoaPods version >= X.Y.Z, which is not satisfied by your current version, Z.Y.X.

I looked at the version of CocoaPods I have in terminal and it says I’m at 1.0.1.

Running an update didn’t work I guess because CocoaPods 1.1 is in beta.

So I’m not exactly sure how to update it up to where I’m good to go.
Unless being out of date doesn’t force like 800 compiler errors? Does that sound like some other issue?

Solution

Execute the following on your terminal to get the latest stable version:

sudo gem install cocoapods

Add --pre to get the latest pre release:

sudo gem install cocoapods --pre

If you originally installed the cocoapods gem using sudo, you should use that command again.

Later on, when you’re actively using CocoaPods by installing pods, you will be notified when new versions become available with a CocoaPods X.X.X is now available, please update message.

Answered By – Sampath D

Answer Checked By – Candace Johnson (BugsFixing Volunteer)

Leave a Reply

Your email address will not be published.