[SOLVED] Interface Builder was unable to determine the type of "Main.storyboard". This may be due to a missing SDK

Issue

I am getting a strange error whenever I try to view a particular storyboard of a project in Xcode. When I click the storyboard in the file directory I get an alert that reads “Interface Builder was unable to determine the type of “Main.storyboard”. This may be due to a missing SDK.”

This only happens with this particular storyboard, I tried creating another storyboard and I was able to view it just fine. I tried reverting back to a previous version of the project when I was able to open the storyboard, but oddly enough this doesn’t fix the error and I get the same alert. I also tried opening the project in an earlier version of Xcode, but to no avail.

If it provides more context, I get an error for the storyboard I get when I try to build the project that reads “The operation couldn’t be completed. (com.apple.InterfaceBuilder error 2001.)”

Any ideas on what causes this or how to fix it?

Solution

This is less complex than you think.

The error is because you mistype something on the source code of Main.storyboard, for example I accidentally put an “ƒ” before the first open tag of Main.storyboard.

1) What you must do is to delete Main.storyboard (select throw to Trash)

2) Go to Trash, move the Main.storyboard to desktop, open with any text editor and fix the code; then “select all” and “copy”.

3) On Xcode, create a brand new Main.storyboard and then press Right click on file and select Open As -> Source code, then paste the fixed code that you have on your clipboard.

4) Right-click on file and select Open As -> “Interface Builder – Storyboard”.

Hope it works for you.

Answered By – eplazai

Answer Checked By – Willingham (BugsFixing Volunteer)

Leave a Reply

Your email address will not be published.